连接Oracle失败 Listener refused the connection with the following error: ORA-12505

使用场景

数据源平台配置了Oracle,在其它工具测试能够正常连接,但数据源平台在确认配置无误情况下点击测试连接提示失败,报错信息提示:Listenerrefused the connection with the following error: ORA-12505,TNS:listener does not currently know of SID given in connect descriptor

解决方案

原因是Oracle有两种连接类型,
1.使用服务名配置方式:jdbc:oracle:thin:@:1521/orclpdb
2.使用SID,配置方式:jdbc:oracle:thin:@:1521:orcl12c
端口后面使用:时jdbc实例会使用SID的方式,而使用/则是使用服务名。
根据Oracle开始设置的为准。当然一般情况下第二种连接只要是两种方式都开启的情况下也是可以进行连接的。
步骤:
把jdbc配置里的orcl的冒号配置为/
在这里插入图片描述
效果:
替换后测试显示连接成功
在这里插入图片描述

Logo

DAMO开发者矩阵,由阿里巴巴达摩院和中国互联网协会联合发起,致力于探讨最前沿的技术趋势与应用成果,搭建高质量的交流与分享平台,推动技术创新与产业应用链接,围绕“人工智能与新型计算”构建开放共享的开发者生态。

更多推荐