心通达开源版OA搭建记录(四)
- 构建打包说明
在编译过程中,会提示很多报错,主要是因为项目里使用的很多都是 Sun JDK 内部的私有 API,不是 Java 标准 API,所以 IDEA(或者 JDK 高版本)会提示它不推荐使用,这个问题,可借助豆包将相关报错的代码文件,一一替换成Java 标准 API即可。
- 部署说明
在不做特殊配置的情况下,将tomcat下webapps里的root文件夹清空,然后将war包解压,进入解压后的文件夹将里面的内容拷贝到root文件夹下,启动服务,不需要带虚拟目录名访问系统。
- 解决Tomcat控制台中文输出乱码问题
进入apache-tomcat-9.0.109\conf目录,编辑logging.properties文件,做如下调整:
- Tomcat启动提示资源不足警告
现象:
26-Oct-2025 07:53:52.491 警告 [main] org.apache.catalina.webresources.Cache.getResource 无法将位于[/WEB-INF/classes/com/xoa/model/version]的资源添加到Web应用程序[]的缓存中,因为在清除过期缓存条目后可用空间仍不足 - 请考虑增加缓存的最大空间。
原因:
Tomcat 的
WebResourceRoot组件会缓存 Web 应用的静态资源(如类文件、配置文件等)以提高访问效率。当缓存空间不足(即使清理了过期条目后仍不足)时,会触发此警告。解决方法:
增加 Tomcat 缓存最大空间(推荐)
通过配置 Tomcat 的Context参数,增大缓存最大容量。具体步骤:
对于独立 Tomcat:在conf/context.xml中添加:
<Context>
<!-- 配置资源缓存参数,单位为KB,以下示例设为100MB(102400 KB) -->
<Resources cachingAllowed="true" cacheMaxSize="102400" />
</Context>
cacheMaxSize:缓存最大容量(默认值通常为 10240 KB,即 10MB),可根据应用规模调整(如 50MB~200MB)。
DAMO开发者矩阵,由阿里巴巴达摩院和中国互联网协会联合发起,致力于探讨最前沿的技术趋势与应用成果,搭建高质量的交流与分享平台,推动技术创新与产业应用链接,围绕“人工智能与新型计算”构建开放共享的开发者生态。
更多推荐



所有评论(0)